Doxywizard usage

Doxywizard is a GUI front-end for configuring and running doxygen.

When starting doxywizard one can specify an existing configuration file to use as argument, otherwise the default settings will be used as a starting point.

When you start doxywizard it will display the main window (the actual look depends on the platform used).

Main window

The user interface consists of the following sections:

Menu options

In the menu bar the following parts are available: File menu, Settings menu and Help menu.

Specify the working directory from which doxygen will run

Using the Select... button a directory can be selected. When doxywizard is started with a configuration file or one is loaded using the open command (see: File menu) the directory of this settings file used as the working directory.

Configure doxygen using the Wizard and/or Expert tab...
Wizard tab
with this tab it is possible to quickly configure the most important settings and leave the rest of the options to their defaults.
Expert tab
with this tab one gains access to the full set of configuration options.
Run tab
with this tab it is possible to run doxygen and view the used settings.

Switching between these tabs is possible, e.g you could start with the wizard tab and then fine tune some settings by switching to the expert tab.

After doxygen is configured you need to save (see: File menu) the configuration as a file to disk. This allows doxygen to use the configuration and also allows running doxygen again with the same settings at a later point in time.

Since some configuration options may use relative paths, be sure to select a working directory that is root of those paths. This is often the root of the source tree and will typically be correctly filled in if the configuration file is stored at this location as well.

Once the configuration file is saved and the working directory is set, you can run doxygen based on the selected settings. Do this by switching to the Run tab, and click the "Run doxygen" button.

Once doxygen runs you can cancel it by clicking the same button again. The output produced by doxygen is captured and shown in the "Output produced by doxygen" pane. Once doxygen finishes, the log can be saved as a text file.

Wizard tab

The Wizard tab is divided into two panes

Left pane
The main topics for easy setting up doxygen. By clicking on a topic the corresponding settings will appear in the Right pane.
Right pane
The wizard's settings pane, in this pane you will find the settings that are available for the selected topic.

The wizard only gives the possibility to quickly setup doxygen, for full control one should use the Expert tab.

Project settings

The fields in the Project pane speak for themselves. Once doxygen has finished the Destination directory is where to look for the results. Doxygen will put each output format in a separate sub-directory by default.

Wizard tab: Project settings

Mode of operating

The Mode pane allows you to select how doxygen will look at your sources. The default is to only look for things that have been documented. Furthermore, the terminology used in the output can be changed to better match the main programming language used (this doesn't affect the way doxygen parses your source code).

Wizard tab: Mode of operating

Output to produce

The Output pane allows you to select what kinds of output doxygen will produce. For HTML and {\LaTeX} there are additional options available.

Wizard tab: Output to produce

Diagrams to generate

Doxygen can produce a number of diagrams. Using the Diagrams pane you can select which ones to generate. For most diagrams the dot tool of the GraphViz package is needed. This needs to be installed separately.

Wizard tab: Diagrams to generate

Expert tab

The Expert tab is divided into a number of panes:

Top left pane
The Topics pane (i.e. sections in the configuration file) that are available. By clicking on a topic the corresponding settings will appear in the Right pane.
Bottom left pane
The help pane, this will be updated when one hovers over the name of a setting in the Right pane.
Right pane
The Settings pane, in this pane you will find the settings that are available for the selected topic. In case the name for a setting is colored red, the setting has a non-default value. In case a setting is grayed out, the setting is depending on another setting that is disabled. Which setting it depends on is indicated in the help pane on the bottom left.
Some options from the Expert tab

The representation of the input field depends on the type of the configuration option.

  • For each boolean option (those options that are answered with YES or NO in the configuration file) there is a check-box. A typical field looks like:
  • For items taking one of a fixed set of values (like OUTPUT_LANGUAGE) a combo box is used. A typical field looks like:
  • For items taking an integer value from a range, a spinbox is used. A typical field looks like:
  • For free form string-type options there is a one line edit field. A typical field looks like:

    Additionally, when the string field should contain a file or a folder name, there are the special buttons and that start a file / folder selection dialog. A typical field for a file looks like:

    and a folder looks like:

    and in case both a file or a folder is allowed, the look is:

    In case a file represents an image, doxygen also tries to display the selected image. Then a typical field looks like:
  • For options taking a list of strings, an editor field is shown with a non-editable list below it. The button adds the string in the editor field to the list and a the button removes the selected string from the list. The button can be clicked to replace the selected item in the list with the string entered in the editor field. A typical field looks like:

    additionally when the list contains file and / or folder names, there are special buttons and that start a file / folder selection dialog. A typical field would for a file looks like:

    and for a folder it looks like

    and in case both files and folders are allowed, the look is:

Run tab

The run tab gives the possibility to run doxygen with the given settings, see the HTML results, see the settings used and save the output as displayed in the output pane.

Run tab
Specify additional command line options for running doxygen
Field to specify extra options used when running doxygen, e.g. for debugging purposes.
Run doxygen
When clicked will start running doxygen. The "Output produced by doxygen" pane shows the messages produced by doxygen while it is running. Before being able to run doxygen the settings have to be saved.
Show HTML output
Clicking this button will open the main HTML output page in the default browser. The button will be enabled after doxygen has finished.
Show configuration
Clicking this button shows the configuration settings that are used when running doxygen. The results will be shown in the "Output produced by doxygen" pane in compact textual form.
Condensed
When checked the "Show configuration" button will only list the configuration settings that differ from the default settings (analogous to doxygen -x).
Save Log ...
Will save the information from the "Output produced by doxygen" pane in a file as specified by the user.

Menu options

File menu

The file menu with a couple of useful items for loading and saving settings.

File menu
Open...
Load a configuration file from disk, based on a file selection dialog. In case unsaved settings exist you will be asked to confirm the action.
Open recent
Quickly load a recently saved configuration file. In case unsaved settings exist you will be asked to confirm the action. This menu item is only accessible when there are recent files in the list.
Save
Saves a configuration file to disk. In case the configuration file has already been set this file name is used otherwise a selection dialog will appear. In case the file already exists a confirmation is required.
Save as..
Saves the current configuration settings to disk with a specific name. This file name will become the currently set file name.
Quit
Leave doxywizard, in case unsaved settings exist you will be asked to confirm the action.

Settings menu

Settings menu
Reset to factory defaults
Restores the factory defaults as the default settings to use. You will be asked to confirm the action. This menu item is only accessible when the current settings differ from the default settings.
Use current settings at startup
Stores the current configuration settings as the default to use next time the GUI is started. You will be asked to confirm the action.
Clear recent list
Clears the "Open recent" list in the File menu. This menu item is only accessible when there are recent files in the "Open recent" list.

Help menu

Help menu
Online Manual
Opens the doxygen manual from the doxygen home page in the system defined default HTML browser.
About
Shows an About dialog with version information.

Go to the next section or return to the index.